Minecraftとタートルと僕

PCゲームMinecraftのMOD「ComputerCraft」の情報を集めたニッチなブログです。

Minecraft1.8.9で動くComputerCraft1.79ですよ!

はじめに

久しぶりの更新です。 大丈夫です! Twitterの書き込みを見るとわかるように私は元気です。

Minecrat1.8.9のススメ

Minecraftの最新版は、とうとうバージョン1.9に突入しましたが、Mod開発の対応はどうしても後手に回りがちです。 Modで遊んでいる方の多くはMinecraft1.8台どころか、まだMinecraft1.7.10に留まっている人も多いのではないでしょうか。

ComputerCraftの最新版であるComputerCraft1.79は、Minecraft1.8.9に対応したバージョンです。

この機会に、心機一転Minecraft1.8.9に乗り換えてはいかがでしょうか。(僕は早速乗り換えました)

ComputerCraft | Programmable Computers for Minecraft

f:id:hevohevo:20160422215426p:plain:w300

CC1.79の良いところ

なにより、比較的新しい(最新とは言ってない)Minecraftに対応していることでしょう。 そろそろMinecraft1.7.10は飽きてきたという人にはうってつけです。

問題点

CC1.79に移行するときの最大の問題点は、Minecraft1.8.9へのそのほかのModの対応状況が悪いことが挙げられるでしょうか。 CC以外のModで、Minecraft1.8.9に対応していないものは結構あるのですよね。

たとえば対応状況がMinecraft1.7.10で止まっているNEI(Not enough Items)とか。 作者のチキボン(chicken_bones)さんお元気なのでしょうか。 噂では有志が対応版出したという話も聞きますが、そのあたりご存知の方、教えてくださいな(他力本願)。

「オレは(僕は)Minecraft1.7.10に生きるぜ!」という方は、ComputerCraft1.76を使いましょう。

(えるぼ さんよりコメントいただきました)

「NEIの代替MODとして、Just Enough Itemsてのが出てますね。操作感はNEIとほとんどかわらないです。ChickenBone氏はリアルが忙しいとかなんとか」

これは良さそう。早速試してみます!

CC1.7系統のうれしい機能を紹介

Minecraft1.8.9用のCC1.79、Minecraft1.7.10用のCC1.76。いずれにせよCC1.7系統を使っていない人は乗換えをお勧めします。

機能が相当強化されていますからね。

たとえば僕のお気に入り機能として、入力補完機能が挙げられます。

この動画は、標準のエディタを開いてプログラムを書き込んでいるところなのですが、 「local mon = p」まで入力した時点で、pからはじまるAPI名や関数名を推測し補完表示してくれるのです。 背景灰色の部分が補完候補を表示している状態で、ここで矢印[↑]キーを入力することで、別の候補を表示します。 たとえば「peripheral」や「paintutils」などなど。

これだ!と思ったら[TAB]キーで補完完了です。

これがあることでプログラミングがかなり楽になるのですよね。

加えて、

標準エディタだけでなく、ターミナル画面におけるコマンド入力時にも補完機能があるのでコマンドの入力がとても楽になりました。 この強力な補完機能があることだけでCC1.7系統はお勧めできます。

Minecraft1.7.10に留まる人も、Minecraft1.8.9へ移行する人も、CC1.7系統をぜひ!